コンテンツへスキップ

最近、忙しくJetpackとかプラグインのアップデートが来るな...とか思ったら、勝手にwordpressが5.2.3にアップデートされていたw

自動アップデートは前からあったシステムではあったけど、前には自動的にアップデートされなかった自分のサイト2つも最近は自動アップデートされる事が多い。

この理由は当然理解していて、WP4.7.2の時に自分が知る限り最も大きな脆弱性の被害がWordpressにあって、アップデートをしてすぐに脆弱性の修正をしなかった日本でも相当沢山の企業や大学とかのサイトが被害に遭い、その被害数「何万」と言うレベルにまでなった。 reed more "【WordPress】5.2.3へのアップデート / PHP バージョンを7.3にアップデートする"

今日、Wordpressのプラグインの脆弱性をチェックしていたら、ギエェェー

自分が使っているプラグインがビンゴしてしまった...と言うか、4月に警告が出ていて、今まで気付かなかった自分もバカとしか言いようが無いんだけど。 reed more "【WordPress】脆弱性があるプラグイン使用の一時停止 ”Yuzo Related Posts”"

今、自分の両サイトを見てびっくらこいたけども、サーバーの方でphpバージョンが7.2から7.3に自動的に移行した為に、7.3に対応していないWPプラグインが一斉エラーを吐くと言う状態になっておりました(汗)

応急措置的に7.2に戻したけども、来月からphp7.2はサービス終了と言う事で、今後、php7.3に対応してないWPプラグインを断定し訂正を加える為、そのテストでサイトの表示がおかしくなるような事があったらお許し下さい。なるべくお客さんが居ない時(夜中とか)にやろうと思っております。

気付くの遅くなってしまったけど...と言うのも自分の両サイトは背景が黒で、そこに黒字でエラーが出ていた為に見えなくて今頃サイトがエラーを吐いていた事に気付いたw(お見苦しいサイトを見せてしまって申し訳ありません)

WordPressの5.2バージョンが来て、それに伴ってプラグインのアップデートもかなり来たけども、久々に”WordPress Ping Optimizer”のアップデートが来た。

しかし、このプラグインはphp7.2との相性が悪くて、去年、php7.2にした途端、サイトがエラーを吐くようになった。今回のエラーも全く同じで、まだこのプラグインはphp7.2に対応してないように見える
 
それで、このエラーの修正方法は、前のphp7.2のアップデート記事に書いてあるんでそれを参考にしてください。

全く同じ533行目を書き換えるだけで、エラーは出なくなった。

本家には既に導入していたWordpressプラグインの”Table Press”
このサイトにも導入した際、壁にぶち当たる...とまでは言わないけど、出て来た疑問。
 

Table Pressは、CSSに既にtableのデザインが設定してあれば、それが反映される。
しかし、テーブル一つ一つに任意の横幅(width)の設定を持たせたい場合はどうすればいいのか? reed more "【WordPress】Table Press(プラグイン)のテーブルの横幅の設定"

またバカみたいな問題に突き当たっておりますが。

デザインを新しくした事から各ブラウザで不具合が出てないか確認を続けているけども、今回の問題は、IEとかじゃなくて、Chromeと言う世界で最も使われているブラウザに限って起きている。

それもキャッシュが無い新規のお客さんが来た時とかに限って起きる厄介な問題。だから、サイトの運営者は非常に気付きにくい問題かもしれない。 reed more "【WordPress】Jetpackのコメントフォームを設置した時、Chrome環境でキャッシュが無い時にだけ現れる謎の余白"

php7.2にアップデートして、その時に出たプラグインの不具合潰しの事を書いたばかりですが。実はこっちが今日のメインのお題。(結構、困ったんだよ...)

php7.2の不具合潰しの合間に「Count Par Day」のアップデート(3.5.8)が来て、これは本家サイトだけが入れてるプラグイン。(このサイトにはありません)

そして、その時、なーんも考えずにプラグインの更新のボタンをポチッ。途端、シングルページの冒頭にエラーが出てしまう事になった。

それは今は作者さんが修正してくれて、新しいプラグイン(3.5.9)にすれば問題なく動作する筈(制作者さんに感謝)。 reed more "【WordPress】プラグインを過去バージョンに簡単に戻す方法"

未だに見えないところでサイトの微調整との戦いが続いてますがw

今日は色々とサイトのバグ潰しに走り回っていたけど、自分のところも無事にphp7.2(正確にはphp 7.2.10)にアップデートしました。

もっと早くにこれが出来た筈なんだけど、php7.2にすると一部のプラグインがエラーを吐く為に大した修正でも無いのに(親切な人たちが沢山記事してくれてるのに)、なんか面倒臭くて後回しにしてしまった。 reed more "【WordPress】PHP7.2にアップデート"

サイトのファビコンが反映されないな...とか思っていたところ、本家サイト行ってびっくり。エラーが出て、表示がおかしくなっていてすみませんでした。

最初プラグインが悪さしてるのかと思ったけど、実はサーバーの方のphpバージョンがなぜか7.1から7.2に勝手にバージョンアップした事に問題があった。正確には、あるプラグインがphp7.2に対応しておらず、勝手にphpバージョンがアップデートされた事によりエラーが出るようになった。 reed more "両方のサイトがphpエラーを吐いていた事について"

両方のサイトの調整をする事になったけど、その実行内容を纏めて書いておきます。

スマホで見た時にヘッダーがダサい事とか、TOC+が特定の記事にだけ表示されない...とか、色々と調整する事になりました。 reed more "【WordPress】サイトの調整の備忘録(2018-9/28)"

Scroll Up